Adobe patches Flash Player, urges users to upgrade

Adobe Flash Player updatedAnother Flash Player vulnerability has been announced on Adobe’s website.

This latest security flaw affects version 10.3.181.16 and earlier for Windows, Macintosh, Linux and Solaris. According to Adobe the cross-site scripting vulnerability could potentially be used to take over a user’s machine if they visit a malicious website or click on a dodgy email link.

Adobe is urging users to upgrade to the latest Flash Player, which as of now is version 10.3.181.22 (10.3.181.23 for ActiveX). Download it here.

If you’re unsure about which version you have installed don’t forget about Mozilla’s handy plugin check.

Related:
3DS update adds internet browser plus free game
rysis 2 patch 1.8 goes live, still no DX11 support
Metro: Last Light teaser trailer hits web
Stunning Deus Ex: Human Revolution trailer hits the web
WHQL-Certified GeForce R275 Drivers Out Now
Nintendo DS Lite price falls to $99 next week